Posts by analogMensch

    Potis ersetzen mache ich gerne mit Optokopplern. Meistens reicht es auch schon eine Seite des Potis zu ersetzen, wenn man beide haben will braucht mal eben zwei Optokoppler.

    Die Range damit einstellen zu können ist auch kein Problem, schließlich kannst du über die Helligkeit der LED ja einstellen wie weit du den Phototransistor anfahren willst.

    Klarer Vorteil beim Optokoppler wäre, dass du ein potentialfreies Signal hast.

    Sie Simon schon sagt, ich glaube ich würde das auch digital lösen. ATtiny oder ATmega, die sind doch gut für soetwas :)

    Ich programmiere mir gerade auch einen universellen Fußschalter/-taster/Midioutput für mein Board, und der ATmega macht sich da richtig gut. Vor allem, weil ich Werte auch speichern lassen und nicht beim Strom abziehen weg sind.

    Manchmal habe ich ja gute Ideen! :D Wie etwa die Programmierschnittstelle über Miniklinke nach draußen zu führen. Ich hätte mir glaube ich gut in den Arsch gebissen, wenn ich das Ding jedes Mal hätte vom Board schrauben müssen.

    Eine weitere Fußschalter-Option kam dazu, die ich bisher nicht auf dem Schirm hatte: Taster! Ja, einfach nur Verbindung zwischen Tip und Schaft, solange ich drauf latsche. Für Tap Tempo oder andere Dinge.

    Außerdem habe ich ein bisschen mit Midi gespielt, Hanna hat mir geholfen. Ihr Breadboard ist fertig und wird gerade auch schon genutzt, wenn auch nur als Midi-Adapter. Ihr Time Factor-Delay konnten wir auch jeden Fall schon mal problemlos steuern.

    "Aber am IC müssten die 4,5V eigentlich durchaus da sein, oder zumindest nahe dran."
    Wenn du an den IC-Ausgängen mißt ohne die "+"-Eingänge zu behelligen (was man durch das Anlegen eines DVM dort täte), dann ja.

    Gruß, Bernd

    Nee, das war tatsächlich am Pin 3, also am nicht-invertierenden Eingang gemessen. Scheinbar habe ich mit meinem Multimeter da echt Glück ^^

    Aber zurück zum Thema!

    Ich nehme an dass sollte alles identisch sein?

    Ja, genau das ist der Punkt! Wenn du auf dem Plan oder auf deiner Platine guckst, sind zum Beispiel die markierte Seite von D1 und die Plus-Seite von C5 verbunden und damit auf der gleichen Leiterbahn. Wenn da zwischen dann riesige Widerstände sind, dann ist entweder die Lötstelle oder die Leiterbahn faul.
    Klar, da können eventuell winzige Unterschied sein. Aber einige MΩ Unterschied schon böse!
    Hast du auf der Oberseite an den Bauteilebeinchen gemessen. Lötstellen, gerade nicht saubere, sind da nämlich gerne etwas tricky.

    Um solche Stellen zu finden, suche ich mir immer erst zwei zwei Punkte auf einer Leiterbahn, die einen möglichst kleinen Widerstand aufweisen. Sollten 0Ω sein. Dann kann ich sicher sein, dass diese beiden Punkte schon mal gut verlötet sind.
    Danach gehe ich alle weiteren Punkte auf der gleichen Leiterbahn ab. Wenn irgendein Punkt dann höhere Werte aufweist, dann ist da irgendwo der Fehler.

    Die leitende BE-Strecke von Q1 (ca. 0,65 V) und die Spannung über R3 (bedingt durch den Emitter-Bias-Strom) knüppeln die idealen 4,5 V ganz schön runter.

    Oh, Bernd, da dürftest du Recht haben. Das Verhältnis der 2,2MΩ zu den 3,3kΩ ist schon 'ne Nummer. Fehler meinerseits! :P

    Aber am IC müssten die 4,5V eigentlich durchaus da sein, oder zumindest nahe dran. Ich weiß nicht, welches DVM du hast, aber meines bekommt das hin :D

    @ProgPhil, du könntest alternativ halt auch ohne Spannung dran nur mal die Widerstände messen. Aber miss dann nicht nur am Widerstand selbst, sondern auch mal durch andere Punkte an der Platine.
    Beispiel: R4 könntest du logischerweise an den beiden Enden von R4 messen. Du kannst ihn aber auch an der markierten Seite von D1 und an Pin 3 vom IC messen. Oder auch an der Plus-Seite von C5 und an der Minus-Seite von C2. Verstehst du, wie ich das meine? So kannst du nämlich faule Verbindungen finden.

    Also liegen an 3 und 4 die falschen Spannungen an; zu niedrig.

    Pin 3 und Pin 5 meintest du wahrscheinlich :) Ja, da sollte mehr sein. Wenn deine 9V passen, dann müssten da 4,5V sein, weil das Verhältnis von R4 zu R5 genau 1:1 ist und damit genau die halbe Spannung in der Mitte liegen müsste.
    Da gibt es vier verschiedene Möglichkeiten:
    - Wert von R4 zu groß
    - Wert von R5 zu klein
    - schlechte Lötstellen an R4, und damit höherer Übergangswiderstand
    - irgendwelche ungewollten Verbindungen zwischen R4 und R5 (Litzenreste, Lötzinn oder was auch immer)

    Widerstände kannst du nicht falsche herum verbauen, die sind nicht gepolt. Daran kann es nicht liegen.


    Ich habe auch mal auf den Plan geguckt, aber habe nur Halbwissen (bisher). Die Diode fällt raus, da die lediglich die Polarität des anliegenden Stroms "prüft" (?). Die eigentliche Verstärkung findet in Q1 statt?

    Die Diode ist gegen ihre Stromflussrichtung verbaut, und macht damit bei richtig gepolter Spannungsversorgung erst einmal gar nichts. Erst bei falsch gepolter Versorgung schließt sie die ganze Schaltung kurz und verhindert damit ein versehentliches Zerstören der Bauteile.

    Q1 arbeitet als Buffer. Durch die relativ hohen Werte von R1, R2 und R3 verstärkt dieser, aber nicht besonders viel. Soll er ja auch nicht, du möchtest da ja keine Verzerrung haben ;)

    R1 und R2 machen das Biasing für Q1, genau wie R4 und R5 das für IC machen. Und da diese beiden auch wieder gleiche Werte haben, solltest du da auch 4,5V dazwischen finden.

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Gestern Abend wieder mal live gesehen, immer ein Erlebnis! [Blocked Image: https://musikding.rocks/wcf/images/smilies/biggrin.png] Und heute Morgen mit den dreien gefrühstückt und gefachsimpelt. Schon 'ne coole Truppe, sehr entspannte Menschen!

    Konzerte im Sitzen sind noch wirklich ungewohnt. Aber ja, besser so, als gar keine Konzerte!

    Könnte ein Stromversorgung- oder Bias-Problem sein. Hab gerade mal über den Schaltplan geguckt...

    Stell dein Multimeter mal auf Spannungsmessung (Volt DC) und miss mal die Pins am IC. Die schwarze Messspitze muss auf Ground (bei dir die schwarzen Kabel), mit der roten gehst du die Pins mal durch.

    3 = 4,5V
    4 = 0,0V
    5 = 4,5V
    8 = 9,0V

    Die Werte hängen natürlich davon ab, wie genau die 9V deines Netzteils sind. Aber so ungefähr sollten die passen.

    Pin 1 ist eigentlich immer markiert, oder es gibt eine Kerbe auf der Oberseite zwischen Pin 1 und Pin 8.
    [Blocked Image: https://www.musikding.de/media/image/product/120/lg/tl072.jpg]

    Das mit der Ausrichtung von Transistor und IC war auch mehr so Basic, was Troubleshooting angeht :) Heißt noch lange nicht, dass es bei dir falsch ist ;)

    Das mit den Buchsen ist in der Zeichnung wirklich ein bisschen unglücklich. Meine Erfahrung bei den offenen Buchsen ist halt, dass das Lötauge gegenüber vom Kontakt sitzt. Außer beim Schaft selbst, aber der sitzt einfach direkt am Gewinde :)

    Wenn es so ist wie ich denke, dann müsste das blaue Kabel dahin, wo das schwarze gerade sitzt. Das ist der der letzte Kontakt an der Buchse (Spitze/Tip). Und das schwarze müsste eigentlich an das mittlere Lötauge, dass bei dir frei ist.
    Aber wie schon gesagt, wenn du da nur Mono-Stecker rein steckst dann kann das auch auf dem mittleren Kontakt (Ring) bleiben. Das liegt einfach daran, dass Mono-Stecker keinen Ring haben, und deswegen sowieso die Kontakte von Ring und Schaft eins sind.
    Wenn du auf Nummer sicher gehen willst, dass das auch mit Stereo-Steckern keine Probleme gibt, dann verbindest du Ring und Schaft mit dem schwarzen Kabel. Dann hättest du aus deinen Stereo-Buchsen sozusagen Mono-Buchsen gemacht :)

    Moin! :)

    Das erste was ich sehe (oder glaube zu sehen) sind falsch verkabelte Klinkenbuchsen.

    1.) Du nutzt Spitze und Ring anstatt Spitze und Schaft. Wenn du Mono-Stecker drin stecken hast, geht das tatsächlich auch und erhöht sogar die Kontaktsicherheit, weil beim Monostecker der Kontakt für den Ring auf den Schaft greift. Trotzdem würde ich noch den Schaft auf Ground löten.
    2.) Du hast glaube ich Signal und Ground vertauscht, die blauen und schwarzen Kabel an den Buchsen. Normalerweise liegt das passende Lötauge genau gegenüber des Kontaktes. Da hilft im Zweifelsfall das Multimeter weiter.

    Was die Lötstellen anbelangt...die am IC-Sockel sehen gut aus! Wenn du alle so hinbekommst, dann ist das super! :D Muss jetzt nicht unbedingt deine Fehlerquelle sein, aber saubere Lötstellen sind die halbe Miete.
    Sieht ein bisschen aus, als wäre entweder dein Lötkolben nicht heiß genug oder nicht sauber gewesen, oder die Lötstellen wurden zu früh bewegt.
    Bei sowas macht Übung echt den Meister!

    Die Beinchen der LED könnten noch ein Stück gekürzt werden, dann hast du da weniger Kurzschlussgefahr.
    Guck noch, ob IC und Transistor richtig rum in den Sockeln sitzen, dann hast du eigentlich alles machbare an Troubleshooting schon durch.

    Waren keine Platinenhalter mit beim Bausatz, damit die die Platine mit den Löchern festkleben kannst? Isolierband ist da manchmal etwas tricky, gerade wenn die Platine spitze Lötstellen hat die gerne durchs Isolierband durchpieksen.

    So, viel Spaß beim Fehler suchen! :D Irgendwie bekommen wir das Teil da zum Laufen!

    Manchmal wird es auch bei mir ein bisschen digital!

    musikding.rocks/index.php?attachment/422288/

    Um dieses Baby hier geht es...
    Zur Zeit bastele ich wieder ein bisschen an meinem Board rum. Alles in allem bleibt es relativ gleich. Aber so ein paar Sachen wollte ich dann doch machen.

    OK, was ist eigentlich drin?
    Erst mal ist es eine Box mit vier Klinkenbuchsen, DC-Buchse, Fußschalter (oder jetzt Taster) und zwei RGB-LEDs. Zig mal umgebaut, aber immer irgendetwas zum Routen gewesen. Zuletzt war es ein Loop beziehungsweise eine A/B-Box, je nach dem was an Stecker in der linken Buchse steckte (ja, das geht rein mechanisch noch).


    In letzter Zeit hatte ich immer wieder die Idee, mir noch irgendwo einen winziges Gehäuse mit Fußschalter, Klinkenbuchse und LED aufs Board zu quetschen. Einfach um die Option zu haben, noch irgendwas schalten zu können. So nach dem Motto "...in case of...". Aber hatte ich wenig Lust, wirklich zu quetschen, also habe ich mich nie wirklich dran gesetzt.
    Vor einigen Tagen kam mir dann die Idee, dieses Treterchen doch einfach mal wirklich universell zu nutzen.

    Was es jetzt kann?
    - analoger Effekt-Loop (Insert-TRS)
    - Fußschalter-Option No.1 (Tip to Sleeve)
    - Fußschalter-Option No.2 (Ring to Sleeve)
    - Fußschalter-Option No.3 (Tip+Ring to Sleeve)
    - Fußschalter-Option No.4 (Tip/Ring to Sleeve)
    - irgendwelcher digitaler Scheiß, den ich noch nicht ausgeklügelt habe

    Klar, bei so vielen Optionen geht es am besten digital, besonders bei der letzten ist es unumgänglich. Also habe ich einen ATmega 16 da rein gebastelt. Wunderbarer kleiner Controller, dem man eine Menge beibringen kann! Und dabei auch nicht wirklich teuer, mit ein paar Euro gut bezahlbar. Mit Sicherheit hätte es auch ein kleinerer Chip getan, aber von den ATmega16 habe ich einige auf Vorrat.
    Weitere Bauteile waren ein bisschen Beschaltung für den ATmega, zwei Optokoppler, ein 2PDT-Relais und vier Reed-Relais (einfache Schließer-Kontakte).

    Da mein Signal da durch muss, habe ich beschlossen, dass ein bisschen Ausfallsicherheit gar nicht so schlecht ist. Deswegen geht das Signal vom Input über das 2PDT-Relais erst mal zum Output. Direkt über die beiden Öffner-Kontakte, im schlimmsten Fall klaue ich dem Teil also einfach die 18V und habe Sound.

    Genau dieses Relais wird auch im ersten Modus genutzt, in Kombination mit einem der Reed-Relais.
    Im Bypass bleibt das 2PDT-Relais aus, logisch! Zusätzlich legt das Reed-Relais noch den Tip (Send) der Stereo-Buchse auf Ground. Eingeschaltet geht das Signal vom Input zum Send, durch den Loop durch, über Return zurück und dann zum Output.
    Bis dahin also ein ganz normaler True Bypass-Loop mit Relais.


    Die Fußschalter-Optionen waren recht einfach! Das Gitarrensignal hat damit ja gar nichts zu tun und geht komplett unbeeinflusst einfach über das ausgeschaltete 2PDT-Relais direkt zum Output.
    Die Stereo-Buchse schaltet dann je nach ausgewähltem Modus Tip, Ring, beides oder beides abwechselnd auf Ground und damit auf Sleeve.

    Über die digitalen Geschichten habe ich mir noch keine genaueren Gedanken gemacht. Der Plan ist aber so in etwa, Midi über die Stereo-Buchse machen zu können. Midi über Stereo-Klinke ist ja mittlerweile auch nichts seltenes mehr, in der Synth-Welt gibt es das schon seit Jahren auf Mini-Klinke (meistens aus Platzgründen). Und auch bei Gitarren-Technik habe ich da schon einige Varianten gesehen, Lehle macht das zum Beispiel bei ihren Switchern.
    Im letzen Modus liegen Tip und Ring der Stereo-Buchse auf jeden Fall auf den Ausgängen der zwei Optokoppler. Diese werden von zwei Pins des ATmega angesteuert, und können somit prinzipiell erst einmal alles zwischen 0V und 5V raushauen. Sei es jetzt Midi, PWM oder was auch immer, die Optionen sind vielfältig. Bisher kann dieser Modus aber noch nichts außer blinkenden Status-LEDs, da mache ich mir ein anderes Mal Gedanken drüber :D


    So, warum das ganze?

    Ja, ich hatte Lust, eine möglichst universelle Schaltmöglichkeit für Effekte zu haben, die nicht fest auf meinem Board sind. Somit steht mir jetzt die Option offen, das...
    - über einen ganz schnöden, analogen Loop zu machen
    - mit Fußschaltern fernbedienbare Sachen anzusteuern
    - mit Midi oder anderen digitalen Geschichten Sachen anzusteuern

    Jetzt habe ich alles in einem Kästchen. Zwar immer nur eine Option gleichzeitig, aber das sollte hoffentlich reichen.
    Zwischen den Modi umschalten kann man übrigens, in dem man den Fuß zehn Sekunden auf den Taster setzt, bis die LEDs grün leuchten. Dann lässt sich Modus für Modus durchschalten...
    - rot/blau blinkend = Loop
    - einmal bis vier mal rot/rot blinkend = Fußschalter-Option No.1 bis No.4
    - blau/blau blinkend = Digital
    Danach noch mal drei Sekunden drauf latschen, um den Modus auszuwählen, und dann ist er drin!

    Programmieren kann ich von außen über das vierte Loch auf der Rückseite, da sitzt eine 3,5mm-TRRS-Buchse drin.


    Das Teil hat mich die letzten vier Tage etwas Hirnschmalz gekostet. Der Aufbau war ging noch, die kurzen Test-Programme zum Relais und LEDs testen waren auch recht einfach, aber danach wurde es etwas komplizierter. Vor dem MIDI-Teil graut es mir noch ein wenig :/ Bis dahin werde ich glaube ich noch einige Tutorials auf Arduino-Seiten wälzen und viel austesten müssen. Aber hat ja alles Zeit!

    Du meinst direkt zu den Schaltern?

    Oder zumindest mal zur Schalter-Platine. Wahrscheinlich geht ja nur eine Leiterbahn vom IN-Anschluss durch bis irgendwo zu den vielen Anschlüssen für die Fußschalter-Platine. Und von der Platine dann wieder bis zum OUT-Anschluss. Diesen Umweg über die Hauptplatine würde ich komplett vermeiden.


    Was den Gain anbelangt...du hast wahrscheinlich 100kΩ als R3 und R17 verbaut, oder? Wenn ja, dann verändere diesen Wert mal. Diese beiden Widerstände hängen jeweils mit dem Gain-Poti im Feedback-Loop des OpAmps. Um so größer diese werden, desto mehr Gain hast du.

    Du kannst zum Testen einfach den maximal gewünschten Gain einstellen und dann zwischen Pin 2 und 3 des Gain-Potis messen. Das was da an Widerstand ist kannst du von R3 beziehungsweise R17 abziehen.

    Beispiel: Du drehst Drive 1 auf den maximal gewünschten Wert und misst dann 25kΩ zwischen Pin 2 und 3. Heißt also dein Feedback-Loop setzt sich aus den 100kΩ von R3 und den restlichen 75kΩ vom Poti zusammen. Du brauchst also zusammen nur 175kΩ, und nicht wie bei voll aufgedrehtem Poti 200kΩ. Wenn du die 25kΩ von R3 abziehst und dort einen 75kΩ einsetzt, hast du selbst bei voll aufgedrehtem Poti nur die gewünschten 175kΩ.

    Hab ich das soweit verständlich erklärt?

    um interne Rückkopplungen handelt es sich m.E.

    Allerdings fängt das Pedal an zu Pfeifen, wenn man Gain und Lautstärke sehr hoch (also wirklich sehr hoch - eigentlich eher unrealistische Einstellungen) einstellt und beide Seiten einschaltet

    Wenn du den Gain sowieso nie voll ausfährst...je nach Schaltung könntest du je einen seriellen Widerstand zu den Gain-Potis löten. Eventuell müsstest du andere Widerstandswerte passend dazu ändern.
    Hau doch mal den Schaltplan rein, dann guck ich mal drüber :)

    So eine Option die auch noch ganz gut gehen würde wäre, die Verbindung von Input- und Output-Buchse direkt dort hin zu verdrahten, ohne Umweg über die Hauptplatine. Denn...

    Da ist die Wahrscheinlichkeit groß, dass sich Eingang und Ausgang unnötig nahe kommen, oft beschreibt der Signalverlauf ungefähr einen Kreis.

    ...genau das! Es ist nicht unwahrscheinlich, dass Eingang und Ausgang einmal komplett rund rum über die Platine gehen, an ganz viel anderem Kram vorbei.
    Vielleicht sogar mit geschirmten Kabeln. Einfache Signalleitung mit Schirmgeflecht als Ground außenrum reicht meistens schon aus.


    PS: Da war wieder mal einer schneller im Antworten als ich, was die geschirmten Kabel angeht :D Ich war mir aber auch zwischendrin noch 'nen Kaffee machen :P

    Ich hau mal schnell wieder ab, bevor ich Schläge kassiere!

    Besser ist das!


    Eine gleichzeitig? Gleichzeitig mit was?

    Es darf nur eine der drei Stufen gleichzeitig eingeschaltet werden.
    In der Realität sieht das ganze so aus, dass über dem Ventilator auf dem Spitzboden die Steuerung sitzt. Die bekommt einmal ein paar hundert Volt DC vom Netzteil aus dem Keller, und dann geht von da ein steckerfertiges Kabel zum Ventilator. Und an der Steuerung gibt es eine Klemmleiste mit S1, S2, S3 und COM. Für die drei Stufen muss jeweils einer der drei S auf COM gebrückt werden. Genau das sollte eigentlich der Schaltaktor machen, der auf Grund kaputter Busleitung jetzt aber wegfällt. Deswegen muss das jetzt über zwei mal schaltbare 230Vac und Relais gelöst werden.

    Kommt da wirklich keiner drauf? :P Aber ok, der Elektriker vor Ort hat auch nicht verstanden wie er das lösen soll. Der hat einfach nur zwei Installationsrelais in den Kasten nebendran auf die Hutschiene geklatscht und schaltet damit einmal S1 auf COM und einmal S3 auf COM. Dabei reichen genau diese Relais sogar aus, um alle drei Stufen schaltbar zu machen.

    Ich zählte beziehungsweise zählte tatsächlich zu dieser Berufsgruppe. Habe aber vor drei Jahren 'ne ganz andere Richtung eingeschlagen. Aber gekonnt ist halt gekonnt :)

    Ja, Leerrohre wären schön gewesen. Aber in der Realität sieht das meistens anders aus, da wird einfach das Kabel in den Schlitz gestopft und dann kommt der Putz drauf || Darf ja alle nichts kosten und muss schnell gehen.

    Vorschlag des Elektrikers war übrigens, die letzte, noch heile Ader der Busleitung zu nutzen. Und dann stellte er fest, dass de ja nicht bis in den Keller zur Verteilung geht, sondern nur bis zum Schalter an der Schlafzimmertür 8|

    Kleines Denkspiel am späten Abend

    Ein Kumpel von mir hat ein kleines Problemchen! Und zwar eine kaputte Busleitung in deinem Haus. Hat irgendwer wohl versemmelt, die ist geknickt, durchbohrt oder was auch immer. Auf jeden Fall ist die Leitung hinüber, drei von vier Adern getrennt.

    An diese Leitung sollte eigentlich ein kleiner 4fach-Schaltaktor auf dem Dachboden hängen, der die drei Stufen des Deckenventilator und die Beleuchtung schalten sollte. Jetzt ist die Busleitung für den Allerwertesten, es liegt nur noch ein 5x1,5qmm da zur Stromversorgung.

    Sein Elektriker (nicht ich, hab weder die Zeit noch den Elan für Hausinstallationen) hat das 5x1,5qmm zumindest mal belegt, mit Beleuchtung, Stufe 1 und Stufe 3 am Ventilator. Denn so ein 5x1,5qmm hat fünf Adern, drei Phasen, einen Neutralleiter und einen Schutzleiter. Macht nach Adam Riese und Eva Zwerg abzüglich der Beleuchtung zwei Phasen und damit zwei Schaltmöglichkeiten für den Ventilator.

    Sein Problem aktuell: Stufe 1 ist ihm für nachts zu mau und Stufe 3 einfach zu laut. Er hätte gerne Stufe 2.

    Eure Aufgabe jetzt: Macht mir aus zwei Schaltmöglichkeiten (2x230Vac) drei Schaltstufen!

    Wichtig: Es darf immer nur eine Stufe gleichzeitig bestromt werden!

    Ich weiß schon ziemlich genau, wie ich das löse 8) Lediglich mit zwei Relais. Mehr verrate ich euch aber noch nicht :D

    Stromversorgung selbst hat der Ventilator übrigens schon, der Ding läuft tatsächlich auf DC (soll wohl ruhiger laufen). Die zwei Schaltmöglichkeiten sind also allein für die Stufen.

    Here we go! Lasst mal eure Ideen rüberwachsen!