DigiDelay Rauscht

  • External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Das sind jetzt 12db... Ich muss den Frequenz Verlauf steiler und extremer gestalten.


    Edit: ich werde mal die drei 47k widerstände auf 200k oderso erhöhen. Dann komm ich auf 24dB

  • Hmm... Vielleicht ist es ein software Fehler. Folgende Informationsfetzen:

    • Eingang peak voltage 3,5V daraus schließe ich, dass dies auch dem Ausgang entspricht
    • Rauschen bei 5mV
    • ADC mit 12bit (irgendwo hab ich was gelesen von 10bit + 2)

    Ich würde jetzt denken, dass das Rauschen Rundungsfehler im LSB sind. Da 5mV aber etwa nem tausendstel von den 3,5V entsprechen, wäre das LSB bei 10bit etwa ein tausendstel. Bei 12bit müsste das Rauschen eher bei 1mV liegen.
    Die Software ist in Assembler geschrieben, da kann ich mir gut vorstellen, dass an dieser Stelle die Varianten 10bit oder 12bit nicht richtig implementiert wurden.

  • Das ist mir aber zu riskant. Ich mag es nicht, wenn der Eingagnspegel genau stimmen muss. Ich dachte schon daran, ob ich eventuell das signal vorher komprimieren sollte und hinterher wieder expanden. Wie komplex das Schaltungstechnisch ist weiß ich nicht. Was ich aber weiß ist, dass ich dabei die effektive Auflösung schlechter mach.


    Edit: Wie würde sowas denn funktionieren, wenn ich Uout=1/Uin als schaltkreis implementieren möchte?


    Edit2: Ich hab nicht richtig gedacht. Das komprimieren würde während signal da ist das Rauschen sogar verstärken.

  • @cebersp gerade hab ich das delay mal wieder auf dem Board und mache mir gedanken darüber. Leider habe ich keine LEDs verbaut, an denen ich sehen könnte ob er in den begrenzer geht. Bei mir sind es jeweils zwei germanium dioden. Allerdings kann ich das signal doch ziemlich stark boosten ohne, dass die qualität darunter leidet. Am schönsten wäre es, das direkt signal nicht da durch leiten zu müssen und dann noch ein analogen Level regler am ein und ausgang zu haben.


    Ne einfache schaltung für so ne art gradiellen kompressor und anti-kompressor gibt es nicht oder? Der müsste ja nicht wirklich wie ein echter kompressor mit feedback regeln sondern soll bei einem signal von 0 bis 1 den mittleren wert nicht auf 0,5 sondern zB. auf 0,8 abbilden. Und hinter dem teil dann 0,8 wiedeer auf 0,5 zurück mappen.

  • Leider bleibt immer noch relativ viel rauschen

    keine LEDs verbaut, an denen ich sehen könnte ob er in den begrenzer geht. Bei mir sind es jeweils zwei germanium dioden


    Na das ist dann wohl kein Wunder. Am Ausgang vom TL072 liegt dessen Eingangsoffset als permanenter DC-Anteil, da fließt durch die Germaniumdioden eben auch permanent Strom und zu rauschen ist nunmal mit die unangenehmste Eigenschaft dieser Germaniumdioden.

  • Ok, hab gelesen, dass rote LED zwischen 1,6 und 2V brauchen. Deswegen hab ich einfach auf nem breadboard getestet und mich für 1,55V entschieden :)


    Mit "entschieden" meine ich: die LEDs glimmen sich schon bei 1,5V oder weniger. Aber ich hab mich visuell für einen "an"-Zustand via Poti entschieden und dieser war bei 1,55V.


    Dabei fällt mir auf... Es sollten ja 20mA sein. Die kann ich ja ggf messen...


    Shit. Das sind jetzt 1,66V

  • Hab es mal mit den LEDs probiert. Das hat am Rauschen absolut nix geändert...
    Ich weiß mittlerweile aber, dass den Pegel wesentlich heißer fahren kann. Gleichzeitig brauche ich keine Tails und will deswegen zum einen true bypass und zum anderen Das delay ohne direktsignal im Output-level herunterregeln können. Echt blöd, dass hier absolut alles digital gebaut ist. Ich merke sehr wohl, dass dieses Delay ungleich geiler ist als jedes PT2399. Nur muss das rauschen weniger werden und im bypass ohnehin weg.

  • Also nun schaue ich vor allem auf diesen Schaltplan:
    https://electricdruid.net/wp-c…giDelay-Schematic-Pg1.jpg


    Schon in dem construction guide gibt es dieses Bild um das Eingangssignal im Instrumentenlevel und nicht Line-Level zu verarbeiten: https://electricdruid.net/wp-c…017/01/SignalNoiseMod.png


    Ich hab jetzt nochmal R4 auf 100k und R19 auf 220k erhöht. Das klingt immer noch okay und der SNR ist nochmal etwas besser geworden. Was ich nun noch machen möchte ist, dass ich den Output level nicht digital regle sondern auch analog. Dazu hatte ich eigentlich gedacht ich könne beim letzten OpAmp in der Signal-Chain (IC1.2) den positiven und negativen eingang mit nem 1M Poti überbrücken. Leider funktioniert das so aber nicht. Da fehlt mir wieder das verständnis warum das nicht funktioniert. Könnt ihr mal schauen ob ich da nen Denkfehler hab oder ob ich es vielleicht in meinem experiment-aufbau verkackt hab? Effekt ist, dass egal wo der poti steht der level gleich bleibt und erst am letzten ende wo der poti quasi kurzschließt ist das signal weg.


    Mein Ziel ist halt, dass wenn die repeats nur ein Bruchteil der Input Lautstärke haben sollen, dann muss das Rauschen doch nicht trotzdem in voller Lautstärke da sein. Wenn ich digital den output leiser mach verschlechtere ich den SNR und wie oft braucht man das delay tatsächlich genau so laut wie den Input???

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!